Railsにbootstrap導入の際に出てくるエラーの対処法

Ruby on railsでブートストラップ導入ででてくるエラー

RailsにBootstrapを導入する際に出てくるエラー

Udemy講座の「フルスタックエンジニアが教える即戦力Railsエンジニア養成講座」を受講中しています。

授業内でWeb掲示板を作っているのですが、RailsにBootstrapを導入しようとするとエラーがでてきます。

完成図

railsで掲示板作り

エラー

rails-Bootstrap-Error
こんな感じでエラーを吐かれます。
Udemy講座のQ&Aに解決方法を載せてくれている方がいたので、無事解決することができました。
同じエラーが出ていて困っている方は、ぜひ参考にしてみてください。

Gemfile.lockを編集する

CODE
#Gemfile.lockで以下の部分を削除する
autoprefixer-rails(9.0.0)
execjs

Gemfileを編集する

CODE
#Gemfileで以下の部分を追加する
gem 'therubyracer'
gem 'autoprefixer-rails','8.6.5'

あとはDockerを再起動させればオッケーです。

docker-compose build
docker-compose up -d

Dockerのインストール方法

ubuntuにrubyとdockerをインストール UbuntuにRubyとDockerをインストールする方法

ぜひ参考にしてみてください。
終わり。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください